
Graph Editor 

To open the Graph Editor: 

 From the main menu bar, select Windows > Animation Editors > Graph 

Editor  

 from the view menu bar, select Panels > Panel > Graph Editor  

The Graph Editor is a graphical representation of the animated attributes in your 

scene, shown as animation curves. The Graph Editor lets you manipulate 

animation curves and keys within a graph view of a scene.  

Navigating the Graph Editor 

To access the Graph Editor, go to Window → Animation Editors → Graph 

Editor. Now select the ball to bring up its information. The Graph Editor 

should look something like this:  

 

If not, click on or use the f key. As the editor's name implies, the main 

window displays the ball's keyframe information in the form of a graph. The x-

axis corresponds to frames and the y-axis corresponds to attribute values. The 

dark red vertical bar represents the current frame, similar to the time slider in 

the timeline. The black dots represent attribute keyframes and the lines 

connecting them, also known as "animation curves", define how the keys 

interpolate.  



Graph Editor navigation works exactly like camera navigation. Hold down Alt 

and drag the mouse while using either the center mouse button to pan or the 

right mouse button to zoom. Also as with the camera, rolling the scroll wheel 

will zoom. You can select attribute keys by clicking on them or using marquee 

selection, and delete them using Delete.  

As you may have done previously, clicking on will frame the window around 

all of the currently displayed animation curves. If no keys are selected in the 

graph, you can also hit f to do this. If there are keys selected, f will frame the 

selected keys. frames the window based on the timeline's range, and 

centers the existing framing on the current time.  

To move selected keys, hit w to choose the move tool then middle click and 

drag. You can also hold down Shift before moving to lock the move either 

horizontally or vertically, allowing you to edit only the key's frame or edit only 

its attribute value. To scale selected keys, hit r to choose the scale tool then 

middle click drag in the direction you want to scale. Note that the keys will 

scale relative to where the mouse pointer was when the scale operation was 

initiated. Scaling can be useful for quickly changing the extremity of an 

animation, such as altering how high a ball bounces.  

The animation curves are colored based on the attribute list to the left for 

quicker identification. In general, red identifies x based attributes, green 

identifies y based attributes, blue identifies z based attributes, and black is used 

for miscellaneous attributes such as Visibility. By default the graph displays all 

of a selected object's curves. To isolate a single curve click on one of the 

attributes in the list. To figure out which attribute a given curve belongs to, 

select at least one of its keys and a small box will appear next to the appropriate 

attribute in the list.  

 

Graph Editor Tangents 

Tangents describe the entry and exit of curve segments from a key. This menu 

operates on the shape of curve segments around selected keys. Note that these 

settings affect only existing animation curves segments’ tangents.  

Tip:  

If the Graph Editor is displayed in a panel, you can also edit tangents using the 

marking menu. In the Graph Editor, press + s + -click to display the 

marking menu.  



 

Spline  

Specifying a spline tangent creates an animation curve that is smooth between 

the key before and the key after the selected key. The tangents of the curve are 

co-linear (both at the same angle). This ensures that the animation curve 

smoothly enters and exits the key. When animating fluid movement, a spline 

tangent is an excellent place to start. You use a minimum number of keys to 

achieve your look.  

Linear  

Specifying a linear tangent creates an animation curve as a straight line joining 

two keys. If the in tangent type is linear, the curve segment before the key is a 

straight line. If the out-tangent type is linear, the curve segment after the key is 

a straight line. When animating the color of a heating element on a stove, you 

would use linear to achieve that gradual change in color from charcoal gray to 

burning hot red.  

Clamped  

Specifying a clamped tangent creates an animation curve that has the 

characteristics of linear and spline curves.  

The keys’ tangents will be splines unless the value of two adjacent keys are very 

close. In this case, the out tangent of the first key and the in tangent of the 

second key will be interpolated as linear.  

When animating a skeleton in a walk-cycle, you may notice a slipping of the 

pelvic and foot joint position. This occurs because the value of the keys on the 

curve are either the same or close to (within tolerance of) the value of the other. 

Maya assigns a default spline tangent to describe what occurs between these 

keys. This is why you get the joint positions slipping.  

By setting the tangent type to clamped for these keys, the slipping is corrected 

and the tangents becomes a combination of linear and spline.  



In the Maya environment preferences, Clamped is the default tangent type.  

Stepped  

Specifying a stepped tangent creates an animation curve whose out tangent is a 

flat curve.  

The curve segment is flat (horizontal), so the value changes at the key without 

gradation.  

The light from a strobe light turns on and off. To create a strobe-like effect, you 

would use a step tangent.  

Stepped Next  

FBIK animation keys use the stepped next tangent type by default. This tangent 

type differs from regular Stepped tangents in that its interpolation values jump 

immediately to that of the next key, rather than holding the value of the current 

key until the next key is reached.  

Flat  

Sets the in and out tangents of the key to be horizontal (with a slope of 0 

degrees). When a ball reaches its ascent, it hangs in the air for a brief time 

before starting its descent. You can create this effect by using a flat tangent.  

Fixed  

Specifying a fixed tangent allows a key’s tangents to remain unchanged as the 

key is edited.  

When animating a ball, you may find the ball isn’t falling from a desired height, 

yet its impact with the floor and everything else is perfect. Using a fixed tangent 

lets you change the height of the ball while retaining the tangent’s angle. This is 

somewhat different from Edit > Keys > Bake Simulation.  

This process is useful when you want to:  

 Edit a single animation curve instead of all the contributing 

attributes that affect the behavior of a single attribute, for example, 

an object affected by a driven key or an Expression.  

 Add keys to an existing curve  

https://knowledge.autodesk.com/support/maya/learn-explore/caas/CloudHelp/cloudhelp/2015/ENU/Maya/files/GUID-5B3C73B1-8B77-48BA-B0A0-F41ECD236046-htm.html


Plateau  

Plateau tangents ease animation curves in and out of their keyframes like spline 

tangents, but also flatten curve segments that occur between equal-valued 

keyframes like clamped tangents. The plateau tangent normally behaves like a 

spline tangent, but ensures that the minimum and maximum values along a 

curve are all at keyframes.  

Plateau tangents are useful when you want the positions of your keyframes to be 

exact, because they ensure the maximum and minimum values (‘hills and 

valleys’) of the curve do not extend past their keyframes. For example, picture 

an animation of a ball rolling off a table, falling to the floor, and then rolling on 

the floor. With spline tangents, the ball falls through the floor, then comes back 

up to the floor. With plateau tangents, the ball will not fall through the floor. 

The tangents guarantee that your animation will not wander beyond the values 

you keyframed.  

To do this, if a spline tangent would produce a minimum or maximum between 

two keyframes, the plateau tangent flattens the keyframes in question. 

Keyframes at local minimum and maximum points along the curve are also 

flattened. Finally, the first and last keyframe along a curve are always flattened 

if they have plateau tangents.  

Auto  

Auto tangents clamp curve values between frames to a maximum or minimum 

point based on the adjacent keyframe values. Auto tangents are the default type 

for new keys (set as the Default in tangent and Default out tangent in your 

Animation (Settings) preferences).  

Specifying Auto tangents creates an animation curve where the first and last 

keyframes have flat tangents, and keyframes in between do not overshoot the 

neighboring keyframe value. This type of curve prevents issues with 

interpenetration of closely animated objects that can occur with other tangent 

types, such as Spline.  

In Tangent menu  

Lets you specify a type of tangent for the In Tangent only. The In Tangent 

defines the type of curve segment that comes before a key.  

Note: You can also set the Default In Tangent for new keys in the Preferences 

window. See Default In Tangent.  



Out Tangent menu  

Lets you specify a type of tangent for the Out Tangent only. The Out Tangent 

defines the type of curve segment that comes after a key.  

Note: You can also set the Default Out Tangent for new keys in the Preferences 

window. See Default Out Tangent.  

Break Tangents  

Allows manipulation of the in and out tangent handles individually so you can 

edit the curve segment entering or exiting the key without affecting its opposite 

handle.  

Unify Tangents  

Causes the manipulation of an in or out tangent handle to affect its opposite 

handle equally. Unify Tangents retains the relative position of the tangent 

handles even after tangents are individually adjusted (by editing tangents 

separately after choosing Keys > Break Tangents).  

Lock Tangent Weight  

Specifies that when you move a tangent, only its angle can be changed. This 

forces the associated curve segment to retain the weight of the tangent. This 

applies only to weighted curves.  

Free Tangent Weight  

Specifies that when you move a tangent, its angle and weight can be changed. 

This allows the weight of a tangent to be adjusted as well as the angle. This only 

applies to weighted curves.  

 

 

 

 



Time Slider 

The Time Slider controls the playback range, keys, and breakdowns within the 

playback range.  

 

The Current Time Indicator is a gray block on the Time Slider. You can drag it 

to move forward and backward in your animation.  

By default, dragging in the Time Slider updates only the active view. All views 

can be set to update by changing the Playback settings to Update View All in 

the Time Slider preferences ( Window > Settings/Preferences > Preferences).  

Note: See Customize the Time Slider if you want to change the colors and 

opacity of elements in the Time Slider.  

Key ticks 

Key Ticks are red (by default) marks in the Time Slider that represent the keys 

you set for the selected object. Breakdowns are a special type of key displayed 

as green marks in the Time Slider. See Breakdowns.  

The visibility of Key Ticks can be turned off or on in the Preferences window. 

You can also set the size and color of the key ticks displayed in the Time Slider. 

See Customize the Time Slider.  

Time units  

The ruler markings and associated numbers on the Time Slider display time. To 

define the playback rate, select the desired Time unit in the Settings preferences 

(Window > Settings/Preferences > Preferences). Maya defaults to measuring 

time as 30 frames per second.  

Note: By default, Maya plays your animation in seconds. You can change the 

Time unit type without affecting your animation’s key-based behavior, but it's 

a good idea to specify the Time unit before you begin animating.  

https://knowledge.autodesk.com/support/maya-lt/learn-explore/caas/CloudHelp/cloudhelp/2017/ENU/MayaLT/files/GUID-51A80586-9EEA-43A4-AA1F-BF1370C24A64-htm.html
https://knowledge.autodesk.com/support/maya-lt/learn-explore/caas/CloudHelp/cloudhelp/2017/ENU/MayaLT/files/GUID-93108E8C-9763-49D2-9410-17A835D04443-htm.html
https://knowledge.autodesk.com/support/maya-lt/learn-explore/caas/CloudHelp/cloudhelp/2017/ENU/MayaLT/files/GUID-5B605DBF-63DC-44A3-83AE-33EAE2B025F5-htm.html
https://knowledge.autodesk.com/support/maya-lt/learn-explore/caas/CloudHelp/cloudhelp/2017/ENU/MayaLT/files/GUID-93108E8C-9763-49D2-9410-17A835D04443-htm.html
https://knowledge.autodesk.com/support/maya-lt/learn-explore/caas/CloudHelp/cloudhelp/2017/ENU/MayaLT/files/GUID-4D653DC9-57AA-4D8B-987A-5B7A9735CAF0-htm.html


Current time field 

The entry field to the right of the Time Slider indicates the current time 

expressed in the current Time unit. You can change the current time by entering 

a new value. Your scene moves to that location in time, and the Current Time 

Indicator updates accordingly.  

 

What is IK/FK 

What is IK 

IK, Inverse Kinematics, refers to a process utilized in 3D computer graphic 

animation. In this process, the parameters of each articulation, in a jointed 

flexible object (a kinematic chain), will be automatically calculated to achieve a 

desired pose, especially when the end point moves.  

Basically speaking, IK is how the child node, as it moves, effects all the parents' 

position and orientation values.  

 

 

Child node selected  
Offsets of all nodes in the chain 

gets affected  

 

What is FK  

FK, Forward Kinematics, is how the positions of particular parts of a model at 

a specified time are calculated from the position and orientation, together with 

any information on them of an articulated model.  

To sum up, FK refers to the effect on the child nodes as the parent moves or 

rotates. 



 

 

Parent node selected  Only parent's offset gets affected  

 

 

Playblast Animation 

A Playblast is a quick preview that lets you make a "sketch" of your animation, 

providing a realistic idea of your final render result without requiring the time 

needed for a formal render. Playblasting gives you a fast way to evaluate your 

work on the fly, taking a screen grab of the animation in the viewport at each 

frame during playback, and then “blasting” those images to an image viewer.  

By default, Playblast generates a movie or images using the active view and the 

current time range in the Time Slider to determine the animation range. The 

default scale is 0.5, which makes the Playblast image resolution one quarter the 

size of the active view.  

  Create or open an animation.  

  Select Window > Playblast > to open the Playblast Options.  

  Select the Format for the playblast output.  

The Encoding drop-down updates automatically with associated codecs.  

Tip: To create an image sequence instead of a movie, set Format to image, 

then select an image format in the Encoding drop-down list.  

  (Optional) Select the codec or image format you want to use from the 

Encoding drop-down list.  

https://knowledge.autodesk.com/support/maya/learn-explore/caas/CloudHelp/cloudhelp/2015/ENU/Maya/files/GUID-43C23394-3709-4D01-B484-2A46258E09FB-htm.html
https://knowledge.autodesk.com/support/maya/learn-explore/caas/CloudHelp/cloudhelp/2015/ENU/Maya/files/GUID-2D865271-2873-4EDB-82C4-7FB9D7B311E7-htm.html


Tip: Set Encoding to global to use the same format you have specified in the 

Render Settings: Common tab.  

  Set the compression Quality value you want.  

  Set Display Size to From Window.  

  Click in a view to make it active.  

  Click Playblast.  

The scene plays in the active view for the playback range in the Time Slider. 

After each time frame is drawn, Maya takes a screen grab of the active view.  

 

Dope Sheet editor 

 From the main menu, choose Windows > Animation Editors > Dope 

Sheet.  

 From the scene view, choose Panels > Panel > Dope Sheet.  

 Click the Open the Dope Sheet icon in the Graph Editor window.  

The Dope Sheet lets you edit event and sound synchronization and timing.  

Use the Dope Sheet to manipulate key times, represented as colored rectangles 

in the view area. The blocks represent integer time units along the horizontal 

axis. The vertical axis represents the items currently loaded into the Dope Sheet 

outliner.  

The Dope Sheet editor contains menu bar, icons, outliner, and the view area.  

 

https://knowledge.autodesk.com/support/maya/learn-explore/caas/CloudHelp/cloudhelp/2015/ENU/Maya/files/GUID-546B9BE6-612D-4D21-948E-5DF542CAE64B-htm.html


Draw Walk-Cycle 

Getting Setup 
 

- create a new project called “WalkTakeOne” 

- copy the rig file (generi_rig.mb) to the scenes folder in the new project (do 

NOT open this file. You do not want to edit it directly) 
 

Create a reference to your character before animating it 
 

By creating a reference, you can animate your character without affecting the rig. 

This allows you to go back later and change your original model and the changes 

will then be applied automatically to the animation you have generated. 

- File->new scene 

- File->create reference [options] 
o Under Namespace Options, you can either leave “Use namespaces 

checked” (Maya’s new reference management system) or set Resolve 

All 

o Click “Reference” 
o Select “generi_rig.mb” in the dialog and select “reference” (You 

could use a different model here instead, such as Hogan.)  

- We will not use arm IK, so be sure to turn that off. See the character warm 

up tutorial for details. 
 

Animate Feet Sliding 
 

- reduce the timeline to 20 units (enough for one walk cycle) 

- move to a side view of your character 

- The character will take two steps in the 20 frames. 

- bring up the outliner. (Window->outliner, or Panels-

>savedLayouts->Persp/Outliner) It is useful for selecting body 

parts. 

o Select gerry:foot_ctrl_R under anim_Leg_R. This will be used to 
move the right foot forward 

 

- The character will start in a stride position. We will key the IK handles on 

the feet and pelvis 

o Set the translate z of the R foot ctrl to 4  

o Set the translate z of the L foot ctrl to 0  

o Set the translate z of the cog_ctrl to 2.1 

o  Key the translate parameters for each of these controls 

-  



- Now key the next step 

o Advance the timeline to frame 10 

o Set the translate Z of the L Foot ctrl to be 8 
o Set the translate Z of the Cog_ctrl to be 6.1 
o Leave the right foot where it is 
o Key each of these attributes 

- Now key the next step 

o Advance the timeline to frame 20 

o Set the translate Z of the R Foot ctrl to be12  
o Set the translate Z of the Cog_ctrl to be 10.1 

o Do not move the left foot 

o  Key the values of all three 

- If you play your animation, your character should do a basic shuffle 
 

Adjusting Animation Curves 
 

Ultimately, we want to cycle the frames we’ve recorded to create a continuous 

walk sequence. To do this, we need to adjust the curves. 

- select your character 

- Window->animation editors->graph editor 

- In the graph editor, select the z translate channels for the two feet. 

(Deselect everything, find the channels on the left. Click on one and then 

hold down the apple key and click on the other) 

- View->Frame selected will give you a better view of the curves. 

- Notice the tangents at the end. Select Tangents->flat This will set up the curves 

for sequencing. 

 

Adding Pelvic Twist 
 

The process now is to add more and more detail to your animation. We begin by 

adding twist to the pelvis. 

- go to frame 1 

- select the cog_ctrl 

- adjust the pelvic y rotation to be about 10 

- key this 

- move to frame 10 

- adjust the pelvic y rotation to be about -10 

- to set the final rotation we will copy the first (this is just to give you practice 

with copying) 

o  go to frame 1 

o  MMB drag to frame 20 

o The cog_ctrl should still be selected. Highlight the rotate Y attribute 
in the channel box and RMB->key selected 



 

o  Clicking anywhere on the timeline will reset it 

- Save your animation! Get in the practice of saving frequently and renaming 

your files every so often to create a version history. Also view your 

animation from different angles throughout the animation process. 

 

Add pelvic sway 
 

- go to frame 5 

- rotate the pelvis slightly up on the character’s right side so the hip lifts with 

the leg 

- translate the cog_ctrl to the left so that the weight is more on the support foot 

- go to frame 15 and do the same thing (well, the opposite, actually) 

- What animation principle is being invoked here? 
 

Add bounce to the walk 
 

For this, we will work in the graph editor to see a different way to manipulate your keys 

- Open the graph editor 

- Select the cog_ctrl translate y channel (make sure it is selected) 

- Activate the insert keyframe tool (upper left corner of graph editor, one in 

from the left) 

- With the curve selected, MMB click at frame 5 and 15 on the translate 

curve to add keys 

- Select both these keys (select one and shift select the other) 

- Hit w to select the move tool 

- With the MMB, drag the keys up to about .5. Play the animation to have a 

look at your edit. 
 

Add foot lifts 
 

- go to frame 5 

- lift the left foot off the ground about .7. Set a key. 

- go to frame 15 and do the same thing for the right foot. 

- View your animation. 
 

Add arm motion 
 

- Work on your own to add satisfactory arm swing and head rotation 

- Go to frame 1 and bring the one arm back and slightly behind the character, 

bring the other arm in front with more of a bend 

- Copy these frames to frame 20 
o MMB drag from frame 1 to 20  

o With the two shoulder controls selected, select the channels that 
you changed in the channel editor and RMB->key selected 



o Play your animation 
- Go back and add a key at frame 10 

o Here you want the opposite arrangements of the arms as the opposite 
legs are forward  

- Play your animation and make adjustments as needed. 

- Note, this is very limited animation on the character’s upper body. You will 

need to add more detail than this on your assignment. 

 

Refining your animation 
 

This is a very basic walk cycle. At this point we have not included any of the following: 

- a succession of movement through the spine and into the arms 

- a foot roll along the ground (e.g. add in toe bend) 

- head movement 

- personality! 

- Experiment with refining this basic animation 
 

Cycling the animation 
 

At this point, you can cycle the animation in the graph editor to create a continuous walk. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 



Animating a bouncing ball 

First things first. Before we can animate a believable bouncing ball, we need to 

know how an actual bouncing ball reacts when it bounces. Go find a nice 

rubbery ball – and drop it on the floor. Watch how it reacts to gravity. You 

could also videotape the ball in action and play the video back frame by frame. I 

always encourage students to investigate real world objects they’re trying to 

animate – in this case, experiment with different types of balls, a tennis ball, a 

golf ball, etc. You might not see it now, but this will come in very handy for the 

second part of this tutorial when we’ll be making a ball move like it’s actually 

made of something besides pixels. 

 
A real bouncing ball can be a great resource for an animator.   

Now you’re ready to get started animating in Maya (I’m assuming you already 

know some of Maya’s interface – if not, then review the Autodesk Maya 

documentation and introductory tutorials). First, make sure you have the 

viewport and timeline showing. Now give yourself enough time for a decent 

animation, say, 60 frames. Don’t worry, if you need more, you can add it later.  

Also, it will be easier if you have auto-key mode set to “on.”  The only other 

element you need is a ball. That’s pretty simple, just create either a polygonal or 

NURBS sphere. The size and placement won’t matter for this lesson. 

 

 

http://download.autodesk.com/us/maya/2010help/index.html
http://download.autodesk.com/us/maya/2010help/index.html
http://community.digitalmediaacademy.org/wp-content/uploads/2010/03/Wikipedia_BouncingBall.jpg


Initial Keyframes 

Step 1 

 
Start on frame 1.  Set the viewport to the front view.  Move your sphere 

somewhere up (+Y) and to the left (-X), place the object “up in the air,” so to 

speak. Now press “S” to set a keyframe for all the attributes. 

Step 2 

 
Now, move ahead in the timeline to frame 9 (just an arbitrary choice – we’ll 

adjust timing later).  Move the ball down (-Y) and to the right (+X) so that it 

looks like it’s hitting the “ground.”  The auto-key setting should automatically 

set a keyframe on the changed values. 

http://community.digitalmediaacademy.org/wp-content/uploads/2010/03/Maya-BouncingBallPart1-Step1.jpg
http://community.digitalmediaacademy.org/wp-content/uploads/2010/03/Maya-BouncingBallPart1-Step2.jpg


Step 3 

 
Move ahead to frame 17 and once again move the ball upward (+Y) and to the 

right (+X) so that it looks like it’s in the air again. 

Step 4 

 
Move forward to frame 25 and move the ball down (-Y) and to the right (+X) so 

that it is on the ground again. 

http://community.digitalmediaacademy.org/wp-content/uploads/2010/03/Maya-BouncingBallPart1-Step3.jpg
http://community.digitalmediaacademy.org/wp-content/uploads/2010/03/Maya-BouncingBallPart1-Step4.jpg


Step 5 

 
Repeat the last couple steps, putting the ball in the air at frame 33 and on the 

ground again at frame 41. 

 

 

http://community.digitalmediaacademy.org/wp-content/uploads/2010/03/Maya-BouncingBallPart1-Step5.jpg
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