1) About compositions 
A composition is the framework for a movie. A typical composition includes multiple layers that represent components such as video and audio footage items, animated text and vector graphics, still images, and lights. You add a footage item to a composition by creating a layer for which the footage item is the source. You then arrange layers within a composition in space and time, and composite using transparency features to determine which parts of underlying layers show through the layers stacked on top of them. You render a composition to create the frames of a final output movie, which is encoded and exported to any number of formats.
Simple projects may include only one composition; complex projects may include hundreds of compositions to organize large amounts of footage or many effects.
In some places in the After Effects user interface, composition is abbreviated as comp.
Use the Composition panel to preview a composition and modify its contents manually. The Composition panel contains the composition frame and a pasteboard area outside the frame that you can use to move layers into and out of the composition frame. The offstage extents of layers—the portions not in the composition frame—are shown as rectangular outlines. Only the area inside the composition frame is rendered for previews and final output. 
Each composition has an entry in the Project panel. Double-click a composition entry in the Project panel to open the composition in its own Timeline panel. To select a composition in the Project panel, right-click (Windows) or Control-click (Mac OS) in the Composition panel or Timeline panel for the composition and choose Reveal Composition In Project from the context menu.


1. Rendering is the creation of the frames of a movie from a composition. The rendering of a frame is the creation of a composited two-dimensional image from all of the layers, settings, and other information in a composition that make up the model for that image. The rendering of a movie is the frame-by-frame rendering of each of the frames that make up the movie. For more information on how each frame is rendered, 
2. Though it is common to speak of rendering as if this term only applies to final output, the processes of creating previews to show in the Footage, Layer, and Composition panels are also kinds of rendering. 
3. After a composition is rendered for final output, it is processed by one or more output modules that encode the rendered frames into one or more output files. This process of encoding rendered frames into files for output is one kind of exporting.
The Render Queue panel
In the Render Queue panel, you can manage several render items at once, each with its own render settings and output module settings. Render settings determine such characteristics as output frame rate, duration, resolution, and layer quality. Output module settings—which are applied after render settings—determine such post-rendering characteristics as output format, compression options, cropping, and whether to embed a link to the project in the output file. You can create templates that contain commonly used render settings and output module settings.
Using the Render Queue panel, you can render the same composition to different formats or with different settings, all with one click of the Render button: 
· You can output to a sequence of still images, such as a Cineon sequence, which you can then transfer to film for cinema projection.
· You can output using lossless compression (or no compression) to a QuickTime container for transfer to a non-linear editing (NLE) system for video editing.
· You can output to H.264 or another highly compressed format for playback on mobile devices such as cellular phones or the Apple iPod.
· You can output to MPEG-2 for playback from DVD.


INTRODUCTION
Creator tools are used to create backgrounds, noise patterns, and various other types of effects. In this chapter, you will learn to create some basic effects. Also, you will learn to animate objects in Fusion.
you will create a rolling ball animation by using the controls of the Background tool. The final output of the composition is shown in

The following steps are required to complete this tutorial:
a. Set the frame format.
b. Create a new background.
c. Create a wooden plank.
d. Create the shadow of the wooden plank.
e. Create the base of the wooden plank.
f. Create a ball.
g. Animate the ball, the wooden plank, and the wooden plank shadow.
Setting the Frame Format
In this section, you will specify the frame format settings.
1. Choose File > New from the menubar; a new composition is displayed in the Fusion screen.
2. Choose File > Preferences from the menubar; the Preferences dialog box is displayed.
3. In this dialog box, select Frame Format from the Composition# preferences tree; various 
frame format settings are displayed on the right of the Preferences dialog box. 
4. Choose the New button from the right pane in the Settings area of the Preferences dialog box; the Enter a name for the new image format dialog box is displayed. Next, enter 2048x1556 in the edit box and then choose the OK button.
5. In the Settings area, enter 2048 and 1556 in the Width and Height edit boxes, respectively. 
6. Enter 24 in the Frame rate edit box. Next, choose the Save button to save the changes made.
Creating a New Background
In this section, you will create a background for the composition. 
1. Choose the BG button from the toolbar; the Background1 tool is inserted in the Flow area. 
The Background tool is used to generate solid color and gradient images.
2. Press 1; the output of the Background1 tool is displayed in the left Display View. Next, choose the Fit button from the left Display View toolbar to fit the image in the Display View.
3. In the Background1 tool control window, choose the Pick button; the Color dialog box is displayed. In this dialog box, select the white color swatch from the Basic Colors area and then choose the OK button; the white color output is displayed in left Display View. 
By default, the Solid Color button is chosen in the Color tab of the Background1 tool control window. To use two or more colors, you can choose the Horizontal, Vertical, Four Corner, or Gradient button. If you choose the Gradient button, a green line appears in the Display View. You can change the appearance of the gradient in the Display View by dragging the either end of the green line. You can also define your custom gradient by adding keys to the gradient ramp.


Creating the Ball compulsory 
In this section, you will create a ball.
1. Click in the empty space of Flow area to deselect the selected tool tile, if any. Next, choose the BG button from the toolbar, the Background2 tool is inserted in the Flow area. Next, rename the Background2 tool as Ball.
2. Press 1; the output of the Ball tool is displayed in the left Display View.
3. In the Ball tool control window, choose the Gradient button; controls corresponding to the Gradient button are displayed. Next, choose the Radial button and then specify the parameters as follows: 
Start 
X: 0.69 Y: 0.69 
End 
X: 0.33 Y: 0.31 
4. Click on the first key of the Gradient ramp to select it and set the parameters as follows: 
R: 0.4 Position: 0.51 
5. Click on the last key of the Gradient ramp to select it and set the following values: 
R: 0 G: 0 B: 0
6. Click on the red output of the Ball tool and then drag the cursor to the red output of the Merge4 tool; the Merge5 tool is inserted in the Flow area and a connection between the Ball, Merge4, and Merge5 tools is established. 
7. Press 2; the output of the Merge5 tool is displayed in the right Display View. 
8. Select the Ball tool tile from the Flow area and then choose the Add an Ellipse Mask tool from the left Display View toolbar; the Ellipse1 tool is connected to the Ball tool. 
9. In the Ellipse1 tool control window, enter 0.01 in the Soft Edge edit box. 
10. Select the Merge5 tool tile from the Flow area and then set the parameters of the Merge5 tool in the control window: 
Center 
X: 0.88 Y: 0.68 
Size: 0.15 
After entering the values, the output of the Merge5 and Ball tools is shown in the Display
View Menu
Darken: (Alt+K): Reduces the display intensity of the background image.
Actual Size: (Alt+1): Displays the image sequence at its original size.
Unit Pixel Aspect Ratio: (Alt+S): Displays the image using square pixels.
Frustum Image: (Alt+X) : Toggles the display of the footage in the camera frustum of the 3D
scene viewer.
Frame Boundary: (Alt+9): Toggles display of the frame clipping boundary.
Axis Lines: (Alt+L): Toggles the display of coordinate-frame axis lines.
Lens Distortion Lines: (Alt+I): Toggles the display of the distortion lines.
Masks: (Alt+M): Toggles the display of masks.
Colour Key: (Alt+H): Toggles the display of the colour key mask.
User Features: (Alt+U): Toggles drawing of user-features.
Auto Features: (Alt+A): Toggles drawing of auto-features.
Centre On Selected Feature : (Alt+N): Keeps the image window positioned so the currently
selected user-feature is at the centre.
Feature Tracks: (Alt+C): Toggles drawing of feature tracks.
Feature Labels : (Alt+B): Toggles the display of feature labels.
Search Windows : (Alt+R): Toggles the display of user-feature search areas.
Group Assignments: (Alt+O): Toggles the display of feature group assignment colours.
Constraint Assignments: (Alt+P): Toggles the display of feature constraint assignment
colours.
Tracking Geometry: (Alt+2): Toggles the display of tracking geometry.
Optical Flow: (Alt+Q): Toggles the display of optical flow data.
Solved Features : (Alt+Y): Toggles the display of solved feature positions after a camera
solve.
Missing Features: (Ctrl+M): Toggles the display of projection points for features that aren't
tracked in the current frame.
Projection Errors: (Alt+E): Toggles the display of projection errors after a camera solve.
Ground Plane: (Alt+G): Toggles drawing the ground-plane after the camera solve.
Horizon Line: (Alt+5): Toggles the display of the virtual horizon line.
Group Bounds : (Alt+8): Toggles display of a bounding box around each tracking group.
F-Curve Targets : (Alt+7): Displays the camera corresponding to any F-Curve targets that the
user has drawn. This gives you a preview of the camera F-Curves before improving the camera
solve or copying motion to the main camera.
Modelling Primitives: (Alt+4): Toggles the display of modelling primitives.
Vertex Guides: (Alt+0): Toggles display of the guidelines that help you determine where
modelling primitive vertices should lie in the Image Window.
Stereo Convergence: (Alt+[ ): Toggle displace of the stereo convergence point in 3D viewer
windows.
Test Objects: (Alt+3): Toggles the display of 3D tracking test objects.
Clip Planes: (Alt+D): Toggles the display of the current clip planes in 3D viewer windows.
Depth Cue: (Alt+Z): Change the colour of solved feature points according to their distance
from the camera.
Depth Map: (Alt+6): Toggles the display of depth map.
Depth Mesh: (Alt+J): Toggles the display of the depth mesh in 3D viewer windows.

Tracking Menu
Tracking Parameters: (Ctrl+F2): Displays the tracking parameters window.
New User Feature: (Ctrl+F3): Creates a new user-feature.
New Mask: (Ctrl+F4): Creates a new mask to assist auto-feature tracking or optical flow.
Colour Key...: Opens the colour key window.
Auto Track: (Ctrl+F5): Automatically select and tracks a number of auto features throughout
the shot.
Track and Solve: (Ctrl+F6): Performs auto-feature tracking and camera solving with default
parameters in a single step.
Clean Auto-Feature Tracks: Displays the Clean Auto-Feature Tracks window for removing
badly tracked features.
Survey Data...: Opens the survey data window.
Groups...: Opens the motion groups window.
Constraints...: Opens the feature constraints window.
Clear User Features: Clears all user-features.
Clear Auto Features: Clears all auto-features
Camera Menu
Camera Parameters: (Ctrl+P): Displays the camera parameter window.
Segment Motion Types...: (Ctrl+Q): Displays the segment motion types window, to allow different
motion types to be set for different segments of the camera move.
Lens Distortion...: (Ctrl+L): Displays the lens distortion window.
Estimate Focal Length: (Ctrl+E): Estimates the focal length at the current frame, using manually
drawn coordinate axis lines. If no coordinate axis lines are drawn, a focal length estimation
tool is created.
Solve Motion...: (Ctrl+F7): Solves camera motion in the current shot, displaying a window
containing the Solver Controls.
Statistics...: Opens the statistics window after the camera has been solved, showing numerical
per-frame and per-feature data.
Clean Auto-Features...: Displays the Clean Auto-Features window, allowing you to remove
poorly solved features.
Improve Solution... (Ctrl+F8): Opens the Improve Solution window, where an existing solve
can be improved after feature editing.
Depth Map... : Displays the depth map parameter window.
Orient Scene: (Ctrl+F9): Orient the coordinate system using either user-drawn coordinate
axis lines, or so the ground plane fits selected user/auto features.
Scale Scene...: Opens scene scale window, where the distance between any two features can
be set to a known value.
Transform Camera...: Opens the camera transformation window.
Un-Solve Frames: Open the Un-solve Frames window, allowing specific frames to be
removed from the solution..
Delete Solution: Deletes any camera and object motion data.
Camera Parameters
The Camera Parameters window contains the settings that control the behaviour of the camera
in the shot. It is opened from the Camera>Camera Parameters.. menu. On the left-hand
side of the window are the various controls and menu options. On the right is a diagram illustrating
the current parameters that have been specified. The diagram can be hidden or shown
by clicking the Less/More button at the top-right of the window.
Camera Type: The type of camera used in
the shot: Single Camera, Stereo Camera or
Motion Capture.
Camera Motion: The motion that the
camera undergoes. Options are Free
Motion, Translation Only, Rotation Only,
Linear Translation + Rotation, Planar
Translation + Rotation or Stationary.
shot: Constant Convergence, Variable
Convergence or Parallel.
Camera Preset: Choose a camera preset for the footage (for example, PAL D1, PAL 16:9 etc..
or custom).
Load: Load a previously saved preset into the list.
Save: Saves the current camera settings as a custom preset. For your saved preset to be
picked up automatically when you reload PFTrack, it must be placed in the “presets” folder
where PFTrack is installed.
Frame Size: The size of the image in pixels. The first box contains the image width and the
second the height.
Frame Aspect: The aspect ratio of the image frame.
Principal Point: Specifies the position of the camera principal point as a percentage of image
width/height.
Film Back: Sets the size of the film back area (width and height) in units of either inches or
millimetres.
Pixel Aspect: Specifies the pixel aspect ratio for the footage.
Focal Length: Specifies a variable or constant focal length. You can also specify whether the
focal length is known, unknown or approximately known, and enter the focal length value
and units. If you want to enter a focal length in millimetres, make sure that the camera film
back size is specified correctly because otherwise your focal length measurement will not
correspond to the correct field-of-view.
Close: Closes the camera parameters window.
Color depth (or bit depth) is the number of bits per channel (bpc) used to represent the color of a pixel. The more bits for each RGB channel (red, green, and blue), the more colors each pixel can represent.
In After Effects, you can work in 8-bpc, 16-bpc, or 32-bpc color.
In addition to color bit depth, a separate characteristic of the numbers used to represent pixel values is whether the numbers are integers or floating-point numbers. Floating-point numbers can represent a much larger range of numbers with the same number of bits. In After Effects, 32-bpc pixel values are floating-point values.
8-bpc pixels can have values for each color channel from 0 (black) to 255 (pure, saturated color). 16-bpc pixels can have values for each color channel from 0 (black) to 32,768 (pure, saturated color). If all three color channels have the maximum, pure-color value, the result is white. 32-bpc pixels can have values under 0.0 and values over 1.0 (pure, saturated color), so 32-bpc color in After Effects is also high dynamic range (HDR) color. HDR values can be much brighter than white.
Setting the color depth and modifying color display settings
The color depth setting for a project determines the bit depth for color values throughout a project. 
To set the color depth for a project, do one of the following:
· Alt-click (Windows) or Option-click (Mac OS) the Project Settings button in the Project panel.
· Choose File > Project Settings or click the Project Settings button in the Project panel, and choose a color depth from the Depth menu.
Project Settings button in the Project panel
You can specify a color depth for each render item, which overrides the project color depth when rendering for final output. You can also specify the color depth to use for each output item in the output module settings
To change the format in which color values are shown in the Info panel and in some effect controls, choose an option such as Percent or Web from the Info panel menu. Choosing Auto Color Display automatically switches between 8 bpc, 16 bpc, and 32 bpc, depending on the color depth of the project. 
Though many effects can work with all color depths, some effects work only with lower color depths. You can set the Effects & Presets panel to only show effects that work with your current project color depth 
Comparative advantages of working with each color depth setting
The dynamic range (ratio between dark and bright regions) in the physical world far exceeds the range of human vision and of images that are printed on paper or displayed on a monitor. Low dynamic range 8-bpc and 16-bpc color values can represent RGB levels only from black to white. Low dynamic range color values can represent only a small segment of the dynamic range in the real world.
High dynamic range (HDR), 32-bpc floating-point color values can represent brightness levels much greater than white, including objects as bright as a candle flame or the Sun. 
Set the project color depth to 32 bpc to work with HDR footage or to work with over-range values—values above 1.0 (white) that aren’t supported in 8- or 16-bpc mode. Over-range values preserve the intensity of highlights, which is as useful for synthetic effects such as lights, blurs, and glows as it is for working with HDR footage. The headroom provided by working in 32 bpc prevents many kinds of data loss during operations such as color correction and color profile conversion. Even if you’re using 8-bpc footage and are creating movies in 8-bpc formats, you can obtain better results by having the project color depth set to 16 bpc or 32 bpc. Working in a higher bit depth provides higher precision for calculations and greatly reduces quantization artifacts, such as banding in gradients.
Because 16-bpc frames use half the memory of 32-bpc frames, rendering previews in a 16-bpc project is faster, and RAM previews can be longer than in a 32-bpc project. 8-bpc frames use even less memory, but the tradeoff between quality and performance can be obvious in some images at a project color depth of 8 bpc.
Special considerations for working with high dynamic range color
You can use the HDR Compander effect to compress the dynamic range of a layer with an HDR footage item as its source. In this way, you can use tools that don’t support HDR color, such as 8-bpc and 16-bit effects. When you’re done, use the HDR Compander to undo the dynamic range compression. The HDR Highlight Compression effect lets you compress the highlight values in an HDR image so that they fall within the value range of a low dynamic range image.
Because we can see only a subset of the luminance values in a real-world scene in an HDR image on a monitor, it is sometimes necessary to adjust the exposure— the amount of light captured in an image—when working with an HDR image. Adjusting the exposure of an HDR image is like adjusting the exposure when photographing a scene in the real world, allowing you to bring detail out of very dark areas or very bright areas. You can use the Exposure effect to change the color values of a layer for final output, or you can just adjust the exposure in a specific viewer for preview purposes. 

· To apply an effect or animation preset to a single layer, drag the effect or animation preset from the Effects & Presets panel to a layer in the Timeline, Composition, or Effect Controls panel. 
Note: When you’re dragging an effect or animation preset onto a layer in the Composition panel, the name of the layer under the pointer is shown in the Info panel. If you release the mouse button while dragging an animation preset when the pointer is not over a layer, a new layer is created to hold the animation preset. If you release the mouse button while dragging an effect when the pointer is not over a layer, nothing happens.
· To apply an effect or animation preset to one or more layers, select the layers, and then double-click the effect or animation preset in the Effects & Presets panel. 
· To apply an effect to one or more layers, select the layers, and then choose Effect > [category] > [effect].
· To apply a recently used or saved animation preset to one or more layers, select the layers, choose Animation > Recent Animation Presets, and then choose the animation preset from the list.
· To apply the most recently applied animation preset to one or more layers, select the layers, and then press Ctrl+Alt+Shift+F (Windows) or Command+Option+Shift+F (Mac OS).
· To apply the most recently applied effect to one or more layers, select the layers, and then press Ctrl+Alt+Shift+E (Windows) or Command+Option+Shift+E (Mac OS).
· To apply an animation preset to one or more layers using Adobe Bridge, select the layers, choose Animation > Browse Presets, navigate to the animation preset, and then double-click it.
· To apply the effect settings from an animation preset to the current instance of an effect, choose the animation preset name from the Animation Presets menu for the effect in the Effect Controls panel. 
· To copy effects from one layer to one or more layers, select the effects in the Timeline panel or Effect Controls panel, choose Edit > Copy, select the target layers, and choose Edit > Paste.
Note: Applying an effect or animation preset to a layer selects the layer. 
By default, when you apply an effect to a layer, the effect is active for the duration of the layer. However, you can make an effect start and stop at specific times or make the effect more or less intense over time by using keyframes or expressions or by applying the effect to an adjustment layer. 
Animation presets are applied at the current time.





