 
Character Rigging In Maya - Part 1
By: Steven J. Tubbritsteven_tubbrit@yahoo.co.uk
Introducon
Hello, this is a tutorial to introduce people to the somemes complicated world of character rigging. Aswith all my tutorials, I intend to take you through this with as much help and explanaon of the techniquesas I can.Hopefully, at the end of this tutorial, we'll all have a completed rig for a biped character and a beerunderstanding of the whole process in general, albeit aimed at beginners, I intend to get quite in depthlater on, although like I said before, I will be explaining everything I can as I go along to help theunderstanding of why and what is going on in each secon.In most cases, these tutorials I create start out as being a collecon of notes and ndings of my ownresearch, which, in turn, just so 'I' can understand the processes become easy to read notes, and thendevelop into my own tutorial on the subject maer, in this case, character rigging. I will also delve a lileinto blend shapes, and also how to set up low-poly 'stand in' object for animang with, and how to exportand import animaon from the low-res version to the high-res version.As in other tutorials of this kind, where you get pages and pages of instrucon which is somemes a lilehard to understand and follow, I don't want to do that, instead, what I'm going to do is actually provide amodel of one of my characters for you to work with and follow along properly with thistutorial, this means that you will be geng 'real world' experience as you progress and hopefully learnwhat you need to, to set up your own rigs and soon.Ok, before we move onto the main part of the tutorial, I rstly want to introduce some basic informaonthat will aid us later on in this tutorial,forgive me if it comes across a lile basic right now, but I've aimed this at beginners to start with. Hope youall follow along and enjoy this learning process! :)
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Basic Informaon
Ok, this secon is just to introduce some fairly basic terms before we move on into the main riggingtutorials, provided only as a basic heads up for beginners, who may or may not know these terms andexplanaons.
IK (Inverse Kinemacs) and FK (Forward Kinemacs)Forward Kinemacs (FK)
Forwards Kinemacs or FK as it is more widely known is a way of posing or animang a skeleton each part /bone at a me, for example, in the case of anarm using FK, to animate it reaching forward, you would need to rotate the arm at the shoulder joint, andthen you would need to rotate the joint directly below that at the elbow. It is quite an intuive way toanimate as it provides a good visual way of posing the character just by rotang the joints into posion.
Inverse Kinemacs (IK)
Inverse Kinemacs or IK as it is more widely known is a way of posing or animang a skeleton by using agoal based system, IK, in my opinion would be best described as imagine you have no control of you ownarm, and someone else instead moves it for you, the easiest way for this person to move you arm into therequired posion would be to grab your arm at the wrist and then move it into posion, the whole rest ofthe arm would follow accordingly, this is how IK works. In the case of an arm, you would have shoulder andforearms joints, you would then create an IK chain from the top to the boom, and then when youhave done that, you would select the IK handle that would be created at the boom of the forearm joint(wrist area) and the just move that, the whole arm would then move along accordingly.Maya provides three dierent types of IK Solver, these are (default) ikRPSolver (Rotate Plane), ikSCSolver(Single Chain) and also the IK Spline Handle.These are in turn described as : -
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ikRPSolver
The Rotate Plane IK Solver is the default IK Solver and is probably used the most when seng upcharacters, it is most useful when used in conjuncon with chains in joints such as an arm (where theelbow will need to be rotated into place) or a leg (where the knee will need to be rotated into place). Itessenally has the ability to control the twisng direcon of the chain that it is controlling.
ikSCSolver
The Single Chain IK Solver is used when no twisng acon is required of the joint chain, as in a charactersfoot for example.
IK Spline Handle
The IK Spline Handle is actually quite a powerful handle, it is best used when you would have a complexseries of joints, for example a characters spine ora character who has a tail, in both cases you would require a solver that would simplify the process ofanimang a lot of joints together in the same area at the same me. When a Spline Handle is usedbetween a chain of joints, a Spline is created along the chain, and in turn the CV's (Control Verces) arewhat would be selected and manipulated for animang with, generally the CV's would in turn beconstrained to Cluster Deformers for ease of use when manipulang for animaon.
Constraints
As the Maya Online Help states 'Constraints enable you to constrain the posion, orientaon, or scale of anobject to other objects. Further, with constraints you can impose specic limits on objects and automateanimaon processes.' Constraints are used quite a lot in animaon and character setup, and it'sworthwhile geng to know how they all work, so you can best ulise them within your scenes. Mayaoers a number of dierent types of constraints, these are : -
Point constraints
- Point constraints constrain an object's posion to the posion of one or more objects. For example,constraining a buon to a characters shirt.
Aim constraints
- Aim constraints constrain an object's orientaon so that it always aims at other objects. For example,constraining eyes on a character so that they always look in a parcular direcon.
Orient constraints
- An orient constraint causes an object to follow the orientaon of one or more objects. For example, acrowd scene may require all characters to look in a parcular direcon at the same me, you can orientconstrain all the heads to one main character to set this up.
Scale constraints


 
- A scale constraint causes an object to follow the scaling of one or more objects. For example, constrainingtwo characters together so that when grows (scale Y), the other grows too.
Geometry constraints
- A geometry constraint restricts an object to a NURBS surface, NURBS curve, or polygonal surface (mesh).For example, constraining a drinks can to a characters hand.
Normal constraints
- Normal constraints constrain an object's orientaon so that it aligns with the normal vectors of a NURBSor polygonal surface (mesh). For example, constraining a spider to a character to get it to walk over thesurface correctly.
Tangent constraints
- Tangent constraints constrain an object's orientaon so that the object always points in the direcon acurve. For example constraining a y character to a curve so that it animates along the curve and keeps thedirecon that the curves holds, i.e. if it goes up, the y character would be facing up.
Pole vector constraints
[bookmark: _GoBack]- A pole vector constraint constrains an IK rotate plane handle's pole vector. For example,. controlling theposion of acharacters knee of elbow when animang (more informaon later).Ok, we're done with the basics, I hope I haven't bored you too much yet, now we should be ready to moveonto the main meat of the tutorial, but before we carry on, if your wanng to follow along completely sothat you understand fully what your doing, download this model I have created which we will rig togetheras we progress : -Ok, once you've downloaded this model, extract the contents and open the le up within Maya, you shouldhave something like this : -
 
! Note, In This Screengrab, I Have 'Wireframe On Shaded' Switched On !
Now, it looks slightly dierent to the nice smooth versions posted above, the dierence being this model isthe low-polygon version that I normally build for conversion to either subdivision surfaces or polygonsmoothing. Because it is low-polygon, it will be much easier to set up and rig due to the low overhead anduncomplicated layout, as opposed to the polygonally dense mesh that you would get with a 'smoothed'version. There is some other notes I need to make about the scene, but I will do this as we progress on,now onward we go....
Seng Up The Skeleton
In the scene, open up the the Outliner, Window > Outliner. Within the outliner, you will see two groups,one called Character and the other Guide_Curves, The Character group node contains all of our charactersbody parts, such as his head, hands, legs, teeth, gums and so on, I've grouped them this way just to makethe scene cleaner and more manageable when looking for things, the Guide_Curves group node is a groupcontaing some Nurbs Curves which I have placed around the characters body, the 'Guide' curves will aid usin creang our Skeleton, and will be deleted later on, select the Guide_Curves group node within theOutliner, and then maximises your Perspecve window and press number 4 to display the wireframe, youshould be able to see the Nurbs Guide Curves a lile beer this way, it should resemble this diagram : -
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As you can see, I have set up Guide Curves in some key areas, but not all, this step is not essenal, but Ind it helps me when placing my joints, the key areas I have covered are the centre pivots for the eyes, thehead, the shoulders, each joint area in the ngers, the top of the leg, the knees and the ankle areas. Let'sstart seng up our Skeleton now : -ok, rst things rst, create a new layer and call it Skeleton_L, this will become the layer where we will storeall of our joints. Now that you have created the extra layer, we will now begin placing joints. We will beginwith the legs, press F2 if you are not already in animaon mode, and then select SKELETON > JOINT TOOL,in the Layers Menu, set the Character_L Layer to T for Templated. Although we have guide curves for bothsides of the body, we're only going to be using one side, and then mirroring our joints across to the otherside, we will be using our characters right side as your looking at him when seng up the joints to bemirrored. Now, hopefully you should sll have your Skeleton > Joint Tool sll selected, if not, select itagain, and then in your side view, draw the following joint chain : -
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Now, we're going to move the joints into posion, maximise your Perspecve view by pressing the SpaceBar quickly whilst holding the mouse over it, now switch on Snap To Points : -and then in relaon to where your joints are, snap each joint to the following points on each of the guidecurves, as shown in this diagram : -
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So, essenally, you start from the top of the leg and work your way down when snapping to the joints, withthe 3 nurbs curves, you should snap in this order, 1st - Snap to to middle CV of the top curve, at the KneeArea, you should snap the 2nd Joint to the second CV in from the front of the knee, and then on the 3rdpoint your snapping to, make sure it is the second CV in from the back of the guide curve. In the Layersmenu, switch o the V - Visibility for the Curve_Guides Layer, and in the Charater_L Layer, change it from atemplate to an R - Reference Layer, now snap your next joint to the following Vertex on the sole of thefoot: -And then one more to nish, switch to your side view, and change your snapping to grid snapping insteadand then snap to this grid point at the front of the shoe : -
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Once you've snapped the last one, you should now have a chain of joints for your leg, similar to thisdiagram : -Select the rst Joint you created, joint1, and within the layers menu, right click over the Skeleton_L Layerand click on Add Selected Objects, if you haven't already done so, I would also add a colour to the layer, soyou can easily idenfy what is contained within any given Layer, I've chosen Blue, as it stands out and is
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easy to read. We haven't quite nished just yet though, we will be adding some more joints when we cometo do the reverse foot setup, but that is later, right now, we're going to rename our currently created joints, open up the Outliner, and take a look at your joints, with respect to each one's posion, renamethem like this : -That reads a lot beer now, and you now have a much beer idea of what each joints role will be in thehierarchy. We will now move onto creang the arm joints, so again in the Layers Menu, set theCharacter_L Layer to T for Templated, and set the Curve_Guides back to V - Visible. Switch to the frontview, as this is where we will be placing our joints for the arm, and without any snapping turned on, createthe following joints for the arm, don't worry too much about placement right now, just so long as it roughlymatches this diagram : -Within your Outliner, rename the joints, starng from the rst one, like this :
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Now, we need to place them properly, maximise your Persp view, and keep your outliner open, within it,select the Le_Shoulder joint, now, Snap to the Middle CV on the nurbs curve in that area : -Now, select the Le_Elbow joint, and in the top view, Do Not Snap, move it into posion so it roughlymatches this diagram : -Now, select the Le_Wrist joint, and again, in the top view, move that joint into posion so it roughlymatches this posion : -
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Now, the last joint will be ne, and so will not need moving. Within the outliner, select the rst joint,Le_Clavicle and then add it to the Skeleton_L Layer. Now, let's place the nger joints, in the top view,using Grid Snapping, create the following joints, remember to press Enter when you have created the rstlot, don't worry about where there being placed, as we'll be snapping them into place later : -Next, maximise your Persp view, and then switch o Grid Snapping and instead use Point Snapping, and inturn snap each joint to it's corresponding GuideCurve, when snapping to the Guide Curve, snap to the Middle CV on it. You should end up with somethinglike this : -
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Ok, we're not nished just yet, in your Top View, select the last joint in turn on each nger joints, and theThumb joint, turn your Character_L Layer from T - Template, to R - Reference, one, and 1 by 1 snap tothese points on the end of the actual mesh, see this diagram : -And the last joint in the Thumb Joint hierarchy (Probably best placed in the Persp View) : -
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Now name your joints in turn, starng from the rst set you created, I recommend the following namingconvenon, Le_Pinky_Finger_etc, Le_Index_Finger_etc, Le_Inner_Finger_etc, and nally,Le_Thumb_etc, you can see what I've done here, ( Tip - To save the tedium of repeve typing, type therst name, and then select it, Press CTRL + C to copy it, and then with the next joint, press CTRL + V to pastit in, and then change it to whatyou need ) : -
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And nally, select all the new joints and add them to the Skeleton_L Layer. You can set the Character_LLayer back to template now too. Don't worry about the nger joints not being connected to anything, we'llsort that part out later. Now we're going to move onto creang the Spine joints.
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The SpineRight, let's connue the skeleton setup with the spine. Maximise your side view and create the following joints : -Now, open up the Outliner, and rename the joints starng from the boom up like this : -Ok, now we need to move them into place. Within the Outliner, select the COG(I've called it COG, as thisstands for Centre Of Gravity), and move it into place, so that it sits as best as you can get around themiddle of the character using the side view, to make things a lile easier, turn the character layer to R -Reference, and in the Persp view, snap to this point within the middle of the character : -
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Now select the Head joint, and snap it to the middle CV of the nurbs guide curve which lies in the headarea : -And nally, select the Head_End joint, and snap to the middle vertex on the top of the character model,once you've done this, you can change the character layer back to T - Template, and again, once you'vedone that select the COG Joint and add the whole set of joints to the Skeleton_L Layer : -
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Ok, let's go back to another part of the skeleton, within the Outliner, select the Le_Clavicle joint, andthe Channel Box, in the Translate Z box, type 1 and press Return, now with the Le_Clavicle sllselected, press the down arrow key on the keyboard, it should now jump down the next bone in thehierarchy, the Le_Shoulder joint, now snap that joint back to the middle CV of the nurbs guide curve,basically your snapping it back to the locaon it was at before we moved the Le_Clavicle joint. Now,we've nished with our Guide Curves for the main body now, so open the Outliner and select thefollowing curves within the Guide_Curves group and delete them, once you've done that, you should bele only with the guide curves for the eyes which we will be ulising later. : -
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Right. moving on, if you haven't already done so, template the character and guide_curves layers, sothat we can concentrate on the joints only. We're now going to set up the rest of the leg joints, in theside view, we need to create some more joints that will aid us in the reverse foot setup that we will beproducing, so, in the side view, set up your joints like this, use Grid Snapping, it doesn't maer about theplacement as we will be moving them into place later, press Enter when your done : -Within the Outliner, rename the joints like this : -
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Select the LReverse_Foot joint, add it to the Skeleton_L Layer, now we'll move it into place, turn o gridsnapping, and instead, in the Persp view, vertex snap the LReverse_Foot joint to the Ankle joint like this :-With the LReverse_Foot sll selected, go into the Channel Editor and within the Translate Y box, changethe value to 0, this will make sure our LReverse_Foot setup lies on the ground origin. Now, select each joint and snap to the corresponding joint, i.e. LReverse_Toe Snapped to LToe and so on : -
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Before we move onto the next part, the actual rigging process, we'll need to do one more thing with allof our joints, and that is to orient them. Ok, open the Outliner and select your COG joint, now selectfrom the menu, DISPLAY > COMPONENT DISPLAY > LOCAL ROTATION AXES, you should now getsomething like this : -connue on unl you have done the same for all joints, you will have to do this manually 1 by 1, so justpress G to repeat the last step for each joint in turn when you select it, you will end up with this :-
[image: https://html.scribdassets.com/3s5xn04uo0w4ypq/images/21-a00b94d28c.jpg][image: https://html.scribdassets.com/3s5xn04uo0w4ypq/images/21-a00b94d28c.jpg]


 
Now, select the COG joint, from the menu select SKELETON > ORIENT JOINT and open the opons box,we want to make sure all of our joints local rotaon axes all point in the same direcon, for the COG joint, set it to the following - none, note the Y always points to the next joint, switch o the Hierarchyand Scale opons : -
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Now carry on and do the same for all the other joints 1 by 1, basically, we're reseng all the joints, sothat we can now in turn set each joint to what we want it to be orientated at, once you've done that,you'll noce that all joint orients are the same and all have Y as the Up axis. Now before we connue,we need to download a melscript that will aid us in the orientaon of all of our joints, the script (ByJason Schleifer) we'll be using is called jsOrientJointUI.Mel, and can be downloaded from this address : -Ok, once you've downloaded the script, put it in your usual scripts directory, and then within Maya, typeinto the Command Line in the boom le, jsOrientJointUI; , hilight it, and then drag and drop it ontoyour shelf as shelf item, now click on your latest shelf addion, you should get a pop up menu like this : -Now go back to the original COG joint and then press the down arrow key to move up to the next joint inthe hierarchy, you should have the SpineA joint now selected, and select either Z Up or Z Down, in thecase of SpineA, Z Up should be the one you will be using, carry on, unl you have done all the joints inthat hierarchy, you should be geng results similar to this diagram: -
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What you'll nd is joints slightly lted in one direcon (backover) will require Z Up Orientaon and jointslted forward will require Z Down Orientaon. Note, don't worry about the end joints. Now do the samefor the Leg joints, for the rst joint in the chain, you will probably use Z Up, now carry on doing the samefor the rest of the joints in the legs, and also for the reverse foot joints. Now with the reverse foot joints,select the rst one, it can probably get a bit confusing, so you should orient like this, 1st Joint, Z Up, allother joints, Z Down. Now moving onto the arm, you'll ulise Z Up orientaon all the way along, andagain for the ngers, Z Up too. With the Thumb Joints, you'll again ulise the Z Up Orientaon, now,once you've done, you'll have something like this : -As far as joint orientaon goes, that's it, and the whole reasoning behind doing this, is to make sure allof our joints will rotate in the correct direcon that we require when animang. Next we're going toparent some of our joints together.Character Rigging In Maya Connued (Part 2) - Parenng and Mirroring our nal joints
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Select the LHip joint, and then Shi Select the COG joint, now press P to parent the LHip to the COG Joint, abone will appear between them : -Now do the same with the Le_Clavicle and Neck joint, and then again with the rst joint on each of thengers and the thumb and parent to the Le_Hand joint, you'll end up with something like this : -
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Ok, we've now set up and parented all of our joints, now there's one last thing to do now before we'venished with the skeleton, and that's to Mirror our Joints from the Le Side over to the Right Side. Selectthe Le_Clavicle joint and then from the menu select Skeleton > Mirror Joint and open the opons box,within the opons, select YZ as the Mirror opons and Orientaon as the Mirror Funcon : -Select Mirror, and you should now have the right arm set up, including the parented joint :-Do the same now for the LHip and then again for the LReverse_Foot, that's it, we now have all of our jointsmirrored across. We don't need our Local Rotaon Axes displayed anymore, so select each joint one byone, and then issue the command DISPLAY > COMPONENT DISPLAY > LOCAL ROTATION AXIS, or press G torepeat the last command. Once you've done that to all the joints, open up the Outliner. We need torename our joints that we have mirrored across, essenally we need to dierenate the two sides, so Leand Right is enough to do that, so rename all the mirrored joints so that they are R - Right related, as in : -
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Do the same for the mirrored reverse foot and also for the mirrored arm including all the ngers andthumb. A bit of tedious task but worthwhile in the long run. In cases where you have a number 1 at theend of the name, just remove it. That's it, we're ocially nished with the skeleton setup, now we canmove onto the juicy part, the rigging.....
The Rigging Process
Now we'll start the actual rigging process, now before we connue, I'd just like to point out that you shouldbe used to saving your work quite oen, and geng into the habit of creang new les, just so your notsaving over the same le again and again, and if it crashes you'll have no backup. Anyway, back to thesubject maer, we'll rst begin with our characters legs, seeing as how we already have the reverse foot joints in place. Now, just for the rigging controls and so on, create a new layer, and call it Rig_Controls.The LegsFirst, we need to create some poly objects, select CREATE > POLYGON PRIMITIVES > CONE, and in thechannel box, change the values so that they are the same as the following diagram : -In the side view, snap the object to the knee joint : -
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Press CTRL + D to Duplicate the object, and in the PERSP view, snap to the other knee, now select bothobjects, and in the Channel Box again, change the Translate Z for each to 5. This will move the kneecontrollers in front of the Knees. Select MODIFY > FREEZE TRANSFORMATIONS, and then EDIT > DELETE BYTYPE > HISTORY. Add both objects to the newly created Rig_Controls Layer, select the Cone in front of theLe Knee and rename it to LKnee_PV_Constraint, and again select the Cone in front of the Right Knee, andthen rename that one to RKnee_PV_Constraint. One more thing, open your Hypershade, and create twonew Lambert materials, rename them Le_LambertM and Right_LambertM, make the Le_LambertM aRed Colour, and the Right_LambertM a Yellow Colour, now apply the materials to the appropriate KneeControllers, don't worry, it doesn't mean anything, it's just a quick visual way of determining le and rightssides : -We're now going to create the rst part of our IK Setup for the leg, select SKELETON > IK HANDLE, you nowneed to select the LHip Joint, and then the LAnkle joint, select the IKHandle once done and rename it toikHandle_LAnkle : -
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Now, do the same on the other side, RHip to RAnkle joints, select the IKHandle and rename it toikHandle_RAnkle. Select both IKHandles and add them to the Rig_Controls Layer. Select the geometryLKnee_PV_Constraint, and then SHIFT - SELECT the ikHandle_LAnkle. Now select CONSTRAIN > POLEVECTOR, now select the LKnee_PV_Constraint and try moving it le and right, you'll nd the knee isconstrained to it, press Z to undo any movements you may have added. Do the same now for theRKnee_PV_Constraint and ikHandle_RAnkle. For the rest of the leg setup, I'm going to go through theprocess for the le leg, and then you can repeat the process yourself for the right leg. Select theLReverse_Foot joint, if you've been following this tutorial it's Translate X, Y and Z values in the channel boxwill be about X = 2.243, Y = 0 and Z = -0.44, make a note of what the X value is and then change the X valueto 5, this is just to get it out of the way whilst we are working on the other joints, now select SKELETON > IKHANDLE TOOL, and open the opons box, and change the IKRP Solver to IKSC Solver (Single Chain Solver) : -Once you've done that, select the LAnkle joint and then the LBall joint, the ikSC Solver will be created,select it and rename it to ikHandle_LBall, and then add it to the Rig_Controls layer. Add another IK SCSolver from the LBall joint to the LToe Joint, rename it ikHandle_LToe and add it to the Rig_Controls layer.Remembering the value you noted earlier for the LReverse_Foot, type it in and put it back to it's defaultposion. Select the ikHandle_LAnkle and then SHIFT - SELECT the LReverse_Ankle, and then press P toParent them, if it's easier for you, you can do this in the Outliner. Now do the same for the ikHandle_LBalland the LReverse_Ball, and then again for the ikHandle_LToe and the LReverse_Toe. Select theLReverse_Foot Joint, and try moving it around, you'll nd you now have control of the whole foot, trymoving it backwards and forwards, and also try moving the knee controller with it, you'll see straightawaythe benet of using a reverse foot setup. Once you are happy with what you have, repeat the wholeprocess for the Right Leg.
[image: https://html.scribdassets.com/3s5xn04uo0w4ypq/images/29-ed8386d453.jpg]


 
We don't really want to be selecng joints every me we animate, we ideally want things as easy aspossible to just visually grab and away you go. We have vsiual objects that we can grab for the Kneecontrols, now, let's set up some for the Reverse Foot Setups for the le and right sides. First o, ratherthan this becoming a modelling tutorial, download the following scene le :-Once you've downloaded the le, unzip it and then import it into the current scene. Once you've importedthe scene in, you will noce two new controllers at the base of the feet, note they are coloured, rst thingto do is add them to the Rig_Controls layer, if you have coloured this layer, remove it, otherwise thewireframe colouring won't work, and both controllers will appear the same colour. Note, if you load themin, and they are two dierent colours, just recolour them again, by using DISPLAY > WIREFRAME COLOUR,add the two colours you require, red and yellow and click on Default. You should have something like thisnow within Maya : -
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Now the easy part, select the LReverse_Foot, and SHIFT - SELECT the LFoot_Control, then press P to Parentit, do the same for the RReverse_Foot and the RFoot_Control, now grab either controller and try moving itaround, you'll noce that we now have full control for each leg for both le and right sides. Remember topress Z to undo the last command, just to make sure you go back to your original locaon each me. Now, just some more small things to do before we carry on with the foot setup, select the LKnee_PV_Constraint,you'll noce that in the Channel Editor you have access to Translate X, Y and Z, Rotate X, Y and Z, and ScaleX, Y, Z, and the only one we will be using when animang is actually the Translate X Channel, so we need toset this up so that we don't have loads of uncessary keyframes being set on the other channels, and also tokeep our Graph Editor a lot more dier, so in essence, we only want that Channel to be accessible. So,select the LKnee_PV_Constraint, now le mouse drag over the following channels : -The right click over your selecon, and choose Lock Selected, you'll noce they become greyed out, nowtry scaling or rotang the object, the manipulators that usually appear for Scale or Rotate are also greyedout, now that would be ne, but let's dy this up further, with it sll selected, select WINDOW > GENERALEDITORS > CHANNEL CONTROL, you'll have two secons, Keyable and Non - Keyable, select the samechannels you had selected in the channel editor in the Keyable secon : -
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And then press the MOVE >> buon, you'll now noce in the Channel Editor that you now only have theTranslate X channel to choose from and animate with, making things much easier and more logical for youto work with, now repeat this for the RKnee_PV_Constraint. You can now also do the same forLFoot_Control and RFoot_Control, from these two, we probably won't be using Scale X, Y, Z and Visibility,so get rid of them too. Ok, now we can return to seng up the rest of our foot setup : -Select the LFoot_Control, we're now going to add some extra useful aributes to our Le Foot Controller,I'll take you through what to set up with the Le Foot, and then you can just repeat the same funcons forthe Right Foot. So, with the LFoot_Control sll selected, select MODIFY > ADD ATTRIBUTE, the AddAribute Window will appear, in the Aribute Name, Type Heel_Roll, and give it a Minimum Value of -45,and a maximum value of 45 : -
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In case your wondering why -45 and 45 for the values, let me rst tell you how I calculate them, I'm addingan extra aribute to my foot controller that controls the roll of the heel, so I select not the controller, butthe actual Le Reverse Foot joint, and then I test it's rotaons to see how much I will require, -45 and 45are about as much a I need for the Heel to rotate comfortably when animang, so that is the values I use.Click OK, now, all we've done is added the aribute name to the Le Foot Control, you'll noce it withinthe Channel Editor, now we need to actually set up the connecon, so with the LFoot_Control selected,select WINDOWS > GENERAL EDITORS > CONNECTION EDITOR, then select RELOAD LEFT to load theLFoot_Control, now select your LReverse_Foot joint, and then click on RELOAD RIGHT : -
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If you have a long list within each window, go to Le Display, and switch o Show Non Keyable, and thendo the same for the Right Display. Now in the LFoot_Control, click on the Heel_Roll aribute we have setup, and in the LReverse_Foot, select Rotate X : -Close the window, now select your LFoot_Control object, and then in the Channel Editor, select yourHeel_Roll Aribute, with it sll selected, go back to your Persp view and move the mouse Le and Right onthe screen, you'll noce you now have control of the Heel Rotaon through your LFoot_Control. Now weneed to add some more commonly used aributes to the le foot, using the techniques shown above, addthe following aribute, Heel_Pivot with a Minimum of -30, and a maximum of 75, using the ConneconEditor, connect the Heel_Pivot to the Rotate Z of the LReverse_Foot. Again, add another aribute calledHeel_Lean, with a minimum of -45 and a maximum of 20, then in the Connecon Editor, connectHeel_Lean to the LReverse Foot's Rotate Y. That's the heel controls added to the LFoot_Control now, butwe haven't yet nished, create another aribute called Ball_Roll, with a minimum of 0 and a maximum of50, open up the connecon editor like befoe and load up the LFoot_Control, now select the LReverse_Footand then press the down arrow key 2 mes unl you have the LReverse_Ball joint selected, then ReloadRight, then connect the Ball_Roll aribute to the Rotate X of the LReverse_Ball joint.
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That's the heel and ball taken care of, now we just need to sort out the toes, select the LFoot_Control andadd a new aribute called Toe_Roll with a minimum of 0 and a maximum of 50, then in the conneconeditor, do the same as before, but this me you should be loading the LReverse_Toe joint, then connectthe Toe_Roll to the Rotate X. Next aribute to be added should be called Toe_Pivot and have minimum of-40 and a maximum of 30, then in the connecon editor, do the same as before, loading the LReverse_Toe joint, then connect the Toe_Pivot to the Rotate Z. That's all we'll require for the feet, unless you need amore complicated setup involving toes and so on, but this tutorial is designed to give you the basicunderstanding so that you can then go on and create your own rigs. Now, you'll have to repeat all theabove steps for the right foot, taking into account your minimum and maximum values may change fromle to right. The one's changing will be the Heel_Pivot = Min -75, Max 30, Heel_Lean = Min -20, Max 45,and Toe_Pivot = Min -30 and Max 40.Once you've nished on the RFoot_Control, we now need to one more thing, select theLKnee_PV_Constraint, then SHIFT - SELECT the LFoot_Control and then Press P To Parent them together,do the same on the other side, select the RKnee_PV_Constraint and SHIFT - SELECT the RFoot_Control andthen press P to Parent them. Ok, believe it or not, we're now done with the legs.Now that we've nished with the legs, we'll nish o the rest of the rigging on the lower body before wemove onto the spine and upper body rigging. First o, we need to create our characters main pickcontroller, essenally, the one controller that will select the whole character and everything else aachedto it so we can easily rotate the whole character around and face another direcon, or place the characterwhere we want in a scene, so, rst o, select the COG joint, and using the same principles as we discussedearlier, in the channel editor, select Scale X, Y and Z, And Visibility and right click over them and selectLOCK SELECTED, then open up the Channel Control, Window > General Editors > Channel Control and thenmove the Scale X, Y, Z, And Visibility into the Non-Keyable secon. Now create a Nurbs Circle, Create >Nurbs Primives > Circle, Scale it 7.5 in the X, Y and Z Channels. Rename it to Character_World, then freezetransformaons and delete all history. Using DISPLAY > WIREFRAME COLOUR, make it a green colour, don'tforget to add it to your defaults, and then add it to the Rig_Controls Layer, that's it for that part, we'll bereturning to that controller towards the end of the tutorial to actually connect it to our fully riggedcharacter and give us the ability to move the enre character anywhere we wish. Now, let's build our HipController, to save you the me, I've already built one for you, you can download it here : -Once downloaded, unpack it, import it into your scene, and if it doesn't come across with the wireframecoloured green, make it green, and then add it to the Rig_Controls Layer, I've already snapped it to theCOG joint, it should already be named Hip_Control, and you should now have something similar to thisdiagram : -


 
We need to connect our hip movements now to our Hip_Control, which is very easily done, open up theOutliner, select the COG joint, then Shi - Select the Hip_Control, then press P to Parent them together.Note, I've already taken the liberty of removing the scale, x, y, z and visibility opons for the Hip_Control.And nally, select the LKnee_PV_Constraint and then Shi - Select the Hip_Control, and then press P toParent them, do the same for the RKnee_PV_Constraint too, this will aid in the knees following the hipswhen using the Hip_Control. That's it, select your Hip_Control controller, and have a lile play, you shouldnow have full control of the characters hip movements. Now we can move onto the upper body rigging,starng with the spine.
Rigging The SpineRigging the actual Spine is quite an easy process, and to keep things simple, I've purposely kept awayfrom more complicated techniques, which, you yourself can look at when you are feeling a bit morecondent about your rigging knowledge. From the menu, select Skeleton > ikSpline Handle Tool, thenselect the Spine_A joint, and then the SpineC joint to draw an ikSpline Handle between them. Open upthe Outliner, and select the newly created ikHandle, and rename it to Back_ikHandle, then with themiddle mouse buon, drag it over the top of the COG_Control, this will have the aect of parenng it,then expand the COG_Control, and nd the Spline, it should be named curve1, rename it to Back_Spline,and with it sll selected, select Display > Nurbs Components > Cvs, now select the top CV, then go toDeform > Create Cluster, then rename it to Shoulder_Cluster, it's probably an idea to keep the Outlineropen here, then select the next one down, create another Cluster, and rename it toMiddle_Spine_Cluster, then the next one down, create a Cluster and rename it to Lower_Spine_Cluster :-
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Select the COG_Control, and add two new aributes, Spine_Roll - Minimum = -180, Maximum = 180, andSpine_Twist - Minimum = -180, Maximum = 180. Then open the Connecon Editor, and Reload Le forthe COG_Control, and Reload Right for the Back_ikHandle, then connect the Spine_Twist to the Twist onthe Back_ikHandle, and then connect the Spine_Roll to the Roll on the Back_ikHandle. In the Outliner,select all of the Clusters, and parent them to the COG_Control, and then expand the COG_Control, selectthem again and add them to the Rig_Controls Layer. Select the rst Cluster you create, theShoulder_Cluster, we only really need Translate X, and Translate Z when animang, so lock it's channelsfor all the rest, and then use the Channel Control to move them into the Non-Keyable area so that theydon't display as we discussed earlier on the tutorial if you need to refer back how to do this. Do exactlythe same for the Middle_Spine_Cluster and Lower_Spine_Cluster. Add the Back_ikHandle to theSkeleton_L Layer. We need to create a beer way of selecng those Clusters for the spine, so select theShoulder_Cluster, and then press CTRL + A to open the Aribute Editor for it, set the Cluster Aributesto Relave (Species whether the cluster deformaon occurs only when the cluster deformer handleitself is transformed (moved, rotated, or scaled). With Relave on, only transformaons to the clusterdeformer handle itself cause deformaon eects. Transformaons to any objects parented to the handledo not cause deformaon eects. With Relave o, transformaons to objects parented to the clusterdeformer handle can cause deformaon eects), select the Shoulder_Cluster tab, and then expand theDisplay Secon, select Display Handle, and in the Numeric boxes, change the third one's current valuesto -5, so that the Handle actually resides outside of the characters body, and hence easier to grab. Nowdo the same for the Middle_Spine_Cluster and the Lower_Spine_Cluster using the same -5 value.
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Character Rigging In Maya Connued (Part 3) - The Head Control
Create a Nurbs Circle, and then Scale it to 4.5 in the X, Y and Z channels. Snap it to the Head joint, thenrename it to Head_Control, the freeze transformaons and delete all history. Change the wireframe colourto Green. We'll only really be using the Rotate X, Y and Z for the Head, so lock the other channels, and thenuse the Channel Control to hide them. The main reasoning behind using a Head_Control over standard joint rotaon animaon is this method can be used to eliminate the need to animate the countermovements of the head when moving the body. Thereby making it much faster to animate since it'ssomething we don't need to worry about. We're going to get a lile complicated here, so make sure youfollow the instrucons as carefully as possible, open the Outliner, and nd your Head joint, press CTRL + Dto duplicate it, rename duplicated version to Head_Joint_Constraint, select the Head_Joint_Constraint andthe Head_Joint, and then go to Constrain > Orient, select the Head_Joint_Constraint, and then theHead_Control, then press P to parent it and you can hide it if you wish, but not the Head_Control. Selectthe Head_Control, then press CTRL + G to group it, press W to make sure your in MOVE mode, and thenpress the INSERT key to go into PIVOT mode, using Point Snapping, snap to the Head joint, press Insertagain to come out of pivot mode, now rename the group to Head_Control_Group. Nearly there, select theHead_Control_Group, and duplicate it, then delete all the contents, so that you are only le with an emptygroup, rename this to Head_Control_Group_Constraint, now with Head_Control_Group_Constraint sllselected, also select Head_Control_Group and then go to Constrain > Point, now parentHead_Control_Group_Constraint to the Neck Joint. Now, select your COG_Control and rotate it around,you'll noce that the Head joint always stays up over when moving le, right, forward and back. And if youselect the Head_Control, you'll noce that you also have seperate control of the head movements. Selectthe Head_Control and add it to the Rig_Controls Layer.
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Arms And Shoulders
We're now going to move onto the rigging for the character's arms and shoulders. Let's start with theshoulders, but rst, download the following Nurbs Control Shapes that we will use : -Unpack them, import them into the Maya scene, and even though I have them placed, just to make sure,snap them to your Shoulder joints, and if they're not coloured, colour them accordingly : -
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Select them both and add them to your Rig_Controls Layer. Select the L_Clavicle_Control, then lock thechannels for everything but Translate Y and Translate Z, and then use the Channel Control to make thelocked one's non-keyable. Do the same for the R_Clavicle_Control too. Before we add full control of theshoulders / clavicle to the control objects, we'll set up our arms beforehand, lastly add them to theRig_Controls Layer. With the arms, I'm going to be using an IK Rig, a lot of people use a rig on the arms thatcan switch between FK and IK, in this case, I want to keep things fairly simple, so I'm just going to be usingthe IK setup. Just like the knees we're going to use some elbow constraints, so download these objectsrst, import them into Maya, colour them as before, le and right colours, and add them to theRig_Controls Layer, (note I've also colour coded the wireframe for the polygonal constraints too) : -From the menu, select Skeleton > IK Handle Tool, then select the Le_Shoulder joint and then theLe_Wrist joint, do the same on the other side, selecng Right_Shoulder and Right_Wrist joints. Open theOutliner, select the ikHandle1 and rename it ikHandle_LWrist, and do the same for the ikHandle2 naming itikHandle_RWrist, select them both and add them to the Skeleton_L Layer. Then select theL_Elbow_PV_Constraint and then the ikHandle_LWrist and then go to Constrain > Pole Vector, and then dothe same on the other side for R_Elbow_PV_Constraint and ikHandle_RWrist. You'll noce that when youdo this, the hands may oset themselves slightly out of sync with where they should be, so using anymethod you want, either by rotang the hand joint or using nurbs guide curves again, move them or snapthem back into where you'd like them. If you need to do this, don't forget to re-orient the joints using thescript we used earlier too, I'd recommend starng from the clavicle joints on each side. If your havingproblems doing this, you can download a scene here with this stage set up for you : -Select both the ikHandle_LWrist and ikHandle_RWrist, Create a nurbs circle, rotate it 90 on the Z Axis, andScale it 2 in X, Y and Z, rename it to L_Arm_Control, colour it accordingly for the le side and then snap itto the Le_Wrist joint. Duplicate it, and then do the same for the other side, this me, rename itR_Arm_Control and snap to the Right_Wrist joint, colour accordingly. Freeze Transformaons and deleteall History, and add them to Rig_Controls Layer. Select the ikHandle_LWrist and then the L_Arm_Controland then P to Parent them, do the same on the right side for ikHandle_RWrist and the R_Arm_Control.Select the L_Arm_Control, and Lock the Scale, Rotate And Visbility Channels, and then make them non-keyable using the Channel Control. Do the same for the R_Arm_Control. Select the L_Arm_Control andcreate a new Aribute called Elbow_Twist, do the same for the R_Arm_Control, call it Elbow_Twist as well.Now in the connecon editor, load L_Arm_Control in the le column, and in the right, load theikHandle_LWrist, then connect the Elbow_Twist aribute to the Twist of the ikHandle_LWrist, again, dothe same for the right side too.
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Because we've added an Aribute to control the Twist, we won't be needing the elbow constraintsdisplayed any more, so select them both, and press CTRL + H to Hide them or alternately, it's up to you,lock all channels, and make them non-keyable, which is what I've done.Let's return back to the shoulders, create a Locator, rename it LClavicle_Locator and snap it to theLe_Shoulder joint, add it to the Rig_Controls Layer, select the LClavicle_Locator and then theLe_Shoulder joint and then go to Constrain > Point. Now, parent the locator to the L_Clavicle_Control,create another locator, name it RClavicle_Locator and repeat the same process again. Then parent both Land R Clavicle_Control's to the COG_Control, just so they follow when rotang.The Hands now, create a Nurbs Circle, rotate it 90 on the Z Axis, and Scale it 1.3 in X, Y and Z, rename it toL_Hand_Control, colour it accordingly for the le side and then snap it to the Le_Wrist joint. Duplicate it,rename it R_Hand_Control and snap it to the Right_Wrist joint, colour accordingly, freeze transforms onboth, delete all history, add them both to the Rig_Controls Layer. Select the L_Arm_Control and PointConstrain it to the L_Hand_Control, do the same for the R_Arm_Control and the R_Hand_Control. Selectthe L_Hand_Control and lock the channels for the Translate X, Y, Z Scale X, Y, Z and Visibility and then makethem non-keyable, do the same for the R_Hand_Control. Open the Connecon Editor, Reload Le for theL_Hand_Control, Reload Right for the Le_Wrist Joint, connect the rotaons : -
[image: https://html.scribdassets.com/3s5xn04uo0w4ypq/images/41-9a82d3ceb8.jpg]


 
Do the same for the R_Hand_Control and Right_Wrist joint. Now let's move onto the nger and thumbrigging. We'll start by doing the Le Hand and then move onto the Right Hand.
The Fingers
We're now going to add some extra aributes to the Le and Right Hand_Control objects that will allow usto animate our ngers and thumb for the character. Select the L_Hand_Control, and add the following newaributes : -Add these aributes rst, but with no minimum and maximum values : -
[image: https://html.scribdassets.com/3s5xn04uo0w4ypq/images/42-32857337fd.jpg][image: https://html.scribdassets.com/3s5xn04uo0w4ypq/images/42-32857337fd.jpg]
 
We now need to connect all these aributes via the connecon editor, so open the editor up, and thenReload Le for the L_Hand_Control, we now have a number of things to connect up, so here's the list, justremember to reload right for each item : -Now you're going to need to do the same for the R_Hand_Control, the values will change for the oppositeside, so here's a list for the right side : -and then in the Connecon Editor : -
[image: https://html.scribdassets.com/3s5xn04uo0w4ypq/images/43-cf513c7990.jpg][image: https://html.scribdassets.com/3s5xn04uo0w4ypq/images/43-cf513c7990.jpg]


 
That's it select either your L or R Hand_Control, and check everything is working ok, by selecng what youwant to check in the Channel Editor, and middle mouse scrubbing backwards and forwards in the Perspview, or any other view, note you can select more than 1 item to test, for instance, try selecngInner_Curl_Base, Inner_Curl_Middle and Inner_Curl_Top and then scrubbing you'll see the whole ngercorrespond hopefully. Well, that was quite an intensive part to the tutorial, but at least we've now nishedwith the main body rigging, note you can use these same principles applied to a character's toes, toespread, etc You can download the rig, rigged up to this point here : -
[image: https://html.scribdassets.com/3s5xn04uo0w4ypq/images/44-a8be0b3c19.jpg][image: https://html.scribdassets.com/3s5xn04uo0w4ypq/images/44-a8be0b3c19.jpg]
 
Before we move onto the actual binding process, and the creaon of blendshapes and so on, we need tocreate the nal part of our rig, and that's the rigging for the eyes, which would mean both eyes together,seperately, and for pupil dilaon : -
Rigging The Eyes
Before we connue on the rig the eyes, there's a couple of small things we need to do rst. Open theoutliner, and expand the Character group, you can make the the Character_L Layer non-templated now tooif you wish for beer visualisaon, now select the Nose and Head objects, then from the menu selectPolygons > Combine, you will end up with one object called polySurface1, with polySurface1 sll selected,select the Inner_Mouth_Group Group, and then again, go to Polygons > Combine, then go to Edit > DeleteBy Type > History, to remove all of the empty nodes. Rename polySurface1 to Head, and then add it to theCharacter group, to do this, within the outliner, middle mouse drag it over the top of the Character groupto make it a child of the parent. Now add it back to the Character_L Layer. Now, select both the Eye_Leand Eye_Right groups, and then middle mouse drag them both over the Head object to parent them to it.Finally, with the Head selected, press W to make sure your in Move mode, then press INSERT to go intoPIVOT mode, then point snap the pivot of the head to the Head joint, template the Charater_L Layer tomake things a bit easier when snapping to the joint. Ok, we're now ready to rig the eyes, download thefollowing le and import it into your scene, then colour it green if it isn't already and add it to theRig_Controls Layer, it should be named Main_Eye_Controls : -If they're not already, you can untemplate the Curve_Guides Layer, as we'll be using the last two nurbscurve guides when we rig the eyes. We don't need our Nurbs_Guide curves anymore, as I've used theguides to create the control object above already, right mouse click over Curve_Guides Layer, and thenselect Select Objects, the press DELETE, and then right-click over it again and choose delete. Expand theHead_Control_Group with Outliner, and then parent the Main_Eye_Controls to the Head_Control. Let's setup this controller now, so it actually does something when selected, select the Main_Eye_Controls, lockand make non-keyable the Rotate Z, Translate X, Y, Z, the Scale X, Y, Z and the visibility. Select theMain_Eye_Controls again, and then open the Connecon Editor, Reload Le, then within the Outliner, ndthe head object, and expand it, and then select the Eye_Le group, and then Reload Right. Connect therotaon values of both : -
[image: https://html.scribdassets.com/3s5xn04uo0w4ypq/images/45-23cc121d6b.jpg]


 
Do the same for the Eye_Right group too, then Close the Window. Select the Main_Eye_Controls, thenselect Modify > Centre Pivot, just so our pivot point is in the correct locaon. Let's add an aribute now forthe pupil dilaon, select the Main_Eye_Controls, and add a new aribute called Pupil_Dilaon, min = 0.5and max = 1.4 : -Open the outliner, expand the Character group, nd the Head and then expand that, select both theEye_Le and Eye_Right group. In the Persp view, press F to Fit them fully into view then select Show >Isolate Select > View Selected so that we only have the eyes viewable, select the corneas on the front ofboth eyes, go to Modify > Centre Pivot, and move them up out of the way for now, so that we canconcentrate on the main parts : -Select the Le Eye and then press F to Fit it, select the pupil and iris and select Modify > Centre Pivot, then
[image: https://html.scribdassets.com/3s5xn04uo0w4ypq/images/46-57e5222b8c.jpg][image: https://html.scribdassets.com/3s5xn04uo0w4ypq/images/46-57e5222b8c.jpg]
 
select Display > Nurbs Components > Edit Points, press Insert for both and snap both pivots to the centralCV of the Iris : -Select all of the eye, press 1 for lowest display, then rotate your view so that you are inside the eye lookingthrough it, you can switch o Edit Points now :-
[image: https://html.scribdassets.com/3s5xn04uo0w4ypq/images/47-c025f05226.jpg]


 
Select the L_Eye_Iris, and then select the following CV's :
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With them sll selected, right click over the the L_Eye_Pupil, and select the Middle CV, then go to EditNurbs > Selecon > Grow CV Selecon, Press G to repeat it again, and again, and one more me to makesure, this is to make sure we grab all the overlapping CV's where the Pupil and Iris meet, once you've donethis, deselect the CV's that are outside of the original selecon you made, you should now have somethinglike this : -Go to Deform > Create Cluster, don't worry about the Cluster not displaying as we're sll in Isolate Selectedmode, now repeat this process for the other eye. Once you've done the right eye, select both the corneaobjets that you originally moved up out of the way and move them back, I moved mine up 1 on theTranslate Y, so seng this value back to 0 will put them back into the original posion. select Show >Isolate Select > View Selected so that we have all of our objects displaying again, then open the outliner,nd the two clusters and rename them as Le_Pupil_Cluster and Right_Pupil_Cluster. You can add themboth to the Rig_Controls Layer. Go to the Connecon Editor, Reload Le for the Main_Eye_Controls and forReload Right, load the Le_Pupil_Cluster, and then connect the Pupil_Dilaon to the Scale X, Y and Z, thenReload Right for the Le_Pupil_Cluster, and again connect the Scale X, Y and Z to the Pupil_Dilaon : -
[image: https://html.scribdassets.com/3s5xn04uo0w4ypq/images/49-c147afbbcb.jpg]


 
Select the Le_Pupil_Cluster, and press CTRL + A to bring up it's aributes, within the Cluster aributessecon, turn on Relave, do the same for the Right_Pupil_Cluster. Select the Le and Right Pupil_Clustersand press CTRL + H to Hide them. Close the window, that's it, that's the eyes now rigged. The Head isn'tquite nished yet, but it is nished in terms of rigging, the extras that we will use for the head will be theactual Blendshapes for facial animaon, we'll look at that shortly.Just about ready to start our actual binding, but we will nish here and next me look at Blendshapes:
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